help! and can you explain how to solve it! | Sololearn: Learn to code for FREE!
New course! Every coder should learn Generative AI!
Try a free lesson
+ 1

help! and can you explain how to solve it!

Sum of Consecutive Numbers No one likes homework, but your math teacher has given you an assignment to find the sum of the first N numbers. Let's save some time by creating a program to do the calculation for you! Take a number N as input and output the sum of all numbers from 1 to N (including N). Sample Input 100 Sample Output 5050 Explanation: The sum of all numbers from 1 to 100 is equal to 5050. START SOLVING

4th May 2023, 9:56 AM
BLK
BLK - avatar
9 Answers
+ 5
You should try to make the code by yourself, we can’t help you without a serious attempt of the problem.
4th May 2023, 10:35 AM
Ugulberto Sánchez
Ugulberto Sánchez - avatar
+ 5
Yasin Rahnaward : please keep in mind that: > range(1 , input_number) does *not include input_number*. since the task description demands that the number should be included, we can use: > range(1 , input_number + 1)
4th May 2023, 2:58 PM
Lothar
Lothar - avatar
+ 3
Lothar How many replies you posted here? I can see 2.! The 'task description', you mentioned may be in other thread. Do check again. I can see that from your activity section.
4th May 2023, 3:20 PM
Jayakrishna 🇮🇳
+ 3
Lothar Your answer wasn't deleted by mentors may be you haven't posted correctly.
4th May 2023, 3:22 PM
R💠🇮🇳
R💠🇮🇳 - avatar
+ 1
Create a sum variable and Take an input then use loop over range( one , input number ). Inside the loop add each range value to sum variable.
4th May 2023, 10:01 AM
Yasin Rahnaward
Yasin Rahnaward - avatar
+ 1
Lothar i think there could be two possible reasons other than mentor deleting the posts. 1) op deleted and reposted with your task description. 2) some filters might automatically remove answers (which is less likely as i don't think your answer includes any word that needs to be filtered.)
4th May 2023, 5:28 PM
Sandeep
Sandeep - avatar
0
Hmm, I think it is better to give you a hint instead. Doing this requires a loop that repeat itself multiple times, until it reached the number we mentioned. Also, use the range() function, it will finds out the number from 0(or1) to n-1. To get all numbers in there, you can place -1 before and after the number.ex: range(-1,var-1).(There are some few clues for you to start solving this problem,it is not quite clear actually.)
5th May 2023, 8:18 AM
Dragon RB
Dragon RB - avatar
0
Lothar Does range(-1,var-1) remains the same??
5th May 2023, 8:20 AM
Dragon RB
Dragon RB - avatar
0
Sure, I can help you with that! Here's a simple solution in Python: ``` # take input from user n = int(input("Enter a number: ")) # initialize sum to 0 sum = 0 # loop from 1 to n and add each number to the sum for i in range(1, n+1): sum += i # print the sum print("The sum of all numbers from 1 to", n, "is", sum) ``` This program first takes an integer input `n` from the user. Then, it initializes a variable `sum` to 0. Next, it uses a `for` loop to loop from 1 to `n` (inclusive), and adds each number to the `sum` variable. Finally, it prints out the sum using the `print()` function. When you run this program with the sample input of 100, it will output the sample output of 5050, which is the sum of all numbers from 1 to 100. I hope this helps! Let me know if you have any questions.
5th May 2023, 1:04 PM
Donovan Holzhausen-McCarrick
Donovan Holzhausen-McCarrick - avatar