[Solved] First and Desperate Problem with C++ | Sololearn: Learn to code for FREE!
New course! Every coder should learn Generative AI!
Try a free lesson

[Solved] First and Desperate Problem with C++

Hello guys, I just began studying C++, but I encountered a problem when running the first program on the newest VSCode on Windows 10. There was an error in the #include <iostream> line. VSCode told me to update something called “includePath” and so, which I apparently had no idea about. Please help. Thanks.

3rd Jul 2022, 3:55 AM
Albert Tan
3 Answers
+ 1
Have you installed mingw compiler. Might be you haven't install if am right then install it and configur environment variable path
3rd Jul 2022, 4:54 AM
A S Raghuvanshi
A S Raghuvanshi - avatar
+ 1
Thank you! Problem solved.
3rd Jul 2022, 5:31 AM
Albert Tan
+ 1
FWIW "includePath" is actually the path your preprocessor looks while including your header files in your program, if you have been told to update your include path then it means that for some reason, it was not able to find one or more headers in your system, there are 2 possible reasons for this 1) The header itself is absent : if this is the case then the fix is as simple as installing the header on the system. 2) The header is present but doesn't exist on include path : if it's a custom header that the preprocessor is unable to find them you can simply tell your compiler driver to look for it in a specific place ( -I option in gcc/clang ) If it's a standard header then most probably you didn't configured/installed the language implementation correctly ( though you can still change the default include path but I would still recommend making sure you installed and configured your implementation correctly ).
4th Jul 2022, 1:17 AM
Arsenic - avatar