Pip install not working 😣 | SoloLearn: Learn to code for FREE!

+7

Pip install not working 😣

When I try to install any module on code playground it says to upgrade pip... But when I upgrade pip the rest of the code doesn't work... https://code.sololearn.com/ctAY5Upmexrl/?ref=app If you comment out line 12 you will see the error😥 What should I do...?🙏

8/12/2020 6:01:56 PM

Shreyansh [ #yellove ]

20 Answers

New Answer

+7

Shreyansh upgrading pip is not really a problem. Installing will occur just fine without the upgrade. But still installing 3 packages will take a lot of time Also, you can use an app like PyDroid or termux to use python. There you can install any packagae as they are installed on your local storage.

+7

It is a guess, but seems perfectly logical that upgrading pip is taking time, and as SoloLearn stops execution after a certain amount of time, the rest of the code is never executed.

+6

Namit Jain that is because we are still installing 3 packages which obviously take enough time for SoloLearn to stop execution. If we remove lines 12 through 16, the line gets printed. Furthur proof, try removing every install and upgrade except for install("gcloud") (I tried only gcloud, the others will work too I guess), the line still gets printed

+5

XXX Nice! But remove the line 12 still the line 17 is not printing

+5

XXX what will I do with gcloud... I want firebase 😓 which requires python_jwt module which requires gcloud to be installed... SL should ugrade their pip😔 But for now.. Namit Jain Do you know any platform where I can upload my python code and generate a link... 😜

+5

without upgrading pip bt still installing this three packages 😢 https://code.sololearn.com/cl5p4Jhjti70/?ref=app

+4

SR‎ But it's only one 👦

+4

Namit Jain yes i m showing tht evn without pip upgradation u can't. sl should have these packages pre installd

+4

SR‎ It works but I want firebase 😭 which requires the python_jwt module which requires gcloud... 😂

+2

Shreyansh Hehe 👦😂😂😂

+2

Thanks AKSHAY 🙏👍

+1

Reinstall and check 'ADD TO PATH' during installation

+1

pip install --upgrade pip

+1

Aathmaj Add these lines to your code to install a specific module in your code import os os.system("pip install module_name") Or check this code https://code.sololearn.com/c1wEYq71mzeb/?ref=app

0

Pip has already installed in python 3.4 and apove put you must apply it and I will leave a link to you in YouTube to make it works with you cause the same proplem happened to me when I downloaded pip v. 3.8. https://youtu.be/c_qNC1lL4qA

0

Try this bro. pip install --upgrade pip Then you can install a package pip install name-of-package

0

Hey @Shreynash, It’s not working for me too. I also tried pip install --upgrade pip. Not working😭

0

Don't worry bro, the tide is about to turn. Start by opening a command line(in cmd). Type in the following "py -m pip install -U + module + --user". For example, If I want to install the emoji module, you can do it like this in cmd: py -m pip install -U emoji --user. All this on Windows CMD. Thanks.

0

Codsco How do I open cmd in Iphone? Or is there a cmd in the code playground?

0

Aathmaj, you can try this:(For Iphone) 1. Press to launch or open " Cyndia" on your Iphone's Springboard. 2. Once it opens, press "Install" from the section at the bottom of the screen. 3. Select " Terminal support" from the list. 4. Press or select "MobileTerminal" from the list section. 5. Press the " Install" button at the top right of the screen. 6. Select the "Confirm" button to begin the installation. 7. Once the installation process has completed successfully, press the "Close Window" button. 8. Press the Home button to return to your Springboard. Observe the new mobile terminal icon? Press to launch it. Thanks.