Problem with installing packages with python 3.8 | Sololearn: Learn to code for FREE!

+7

Problem with installing packages with python 3.8

Hi! I recently switched to python 3.8 from 3.7. I had many packages installed in the previous version, but after switching I had to install all the packages again. But the problem is python 3.8 is not installing them to my computer. First it asked to install the VS C++ 14. I was able to install only the numpy and pandas then. But it returns different types of errors for other ones. 1.Matplotlib *This things asks for freetype and png headers. Is this a problem with my C++ installation? I found a link on stackoverflow which provides build packages to this one - but they are for the 3.7 version. 2.Jupyter *This package installs fine but an error occurs when using it. For example if I run jupyter notebook it raises a NotImplementedError. 3.Keras and sklearn *This prints a long error message when installing - so some was hidden in the console. But I found this one which could be helpful C:\...\cython-0.29.7-py3.8-win-amd64.egg\Cython\Compiler\Main.py:367: FutureWarning: Cython directive 'language_level' not set, using 2 for now (Py2). This will change in a later release! File: C:\Users\Pradeep\AppData\Local\Temp\pip-install-7qmjem_8\h5py\h5py\h5a.pxd tree = Parsing.p_module(s, pxd, full_module_name) warning: h5py\api_types_hdf5.pxd:408:2: 'H5D_layout_t' redeclared warning: h5py\api_types_hdf5.pxd:415:2: 'H5D_alloc_time_t' redeclared Again! Is this a problem with my C installation? _______________________________________________________ EDIT: Found this one when installing sklearn (this time via scipy) customize GnuFCompiler Could not locate executable g77 ... don't know how to compile Fortran code on platform 'nt' _______________________________________________________ So my question is am I doing right in this case and are there any solution for any of the above listed packages. Does switching to 3.8 caused all of these errors (because all of these worked well in 3.7) - So should I switch back to the old one? Thanks!

5/15/2019 10:20:31 AM

Seniru

3 Answers

New Answer

+13

Python 3.8 is still in development, you should wait and use 3.7 if you don't want to have these kind of troubles.

+7

I'm also facing this problem. Someone help us !!

0

can any one help me to get python 3.7?