+ 3

Issue in lessons links in the mobile app

Recently I found there are some strange behaviors in a few links. As you may know, you can copy the links of lessons by tapping option and there is a "copy link" button. I noticed this option is disabled in some lessons. Why? Another thing is that I'm now not able to go to lesson by tapping the link copied from "copy link" option directly. It worked before a certain time. I went to Q&A and hope there are similar posts about this, and found https://www.sololearn.com/discuss/1039401/?ref=app It surprises me that the link in the answers work, while the one I copied doesn't. So I try to change the form of my copied links to the following. Before: https://www.sololearn.com/learning/1621/ After: https://www.sololearn.com/learn/CPlusPlus/1621/ It works now. Why does SoloLearn change the working link to the broken one, or it might never works?

16th Apr 2021, 12:00 PM
CarrieForle
CarrieForle - avatar
1 Answer
+ 12
Only Sololearn developers know the answer to this question. So, it is worth sending to [email protected]
19th Apr 2021, 3:45 PM
Igor Makarsky
Igor Makarsky - avatar