0

Why on Android 4.2.2 (IN sololearn!) I have this error: Use of future reserved word in strict mode.

I know that this is due to the fact that use "strict" directive and "let" variables, but when I remove directive and all "let" variables this Error disappears. On other Androids (like 6.0) I have no problem! Maybe this OS of Android is very old but it is very important for me to use this JS code on 4.2.2. And also if I upload HTML file and JS on real server, I have no problem on 4.2.2 How can I fix it on Android 4.2.2 and use "let" variables in Sololearn? Please help

27th Jul 2020, 8:17 PM
Monat15
Monat15 - avatar
1 Answer
+ 1
Yes, you are right, thank you for answer. Today I fix it by running my html and script files in Chrome (which CAN run ECMAScript6), entering into URL field in Chrome word "file://" and then the correct path to my html file. And it works on my Android 4.2.2!
28th Jul 2020, 8:32 AM
Monat15
Monat15 - avatar