Help! Unable to install application. | Sololearn: Learn to code for FREE!

+1

Help! Unable to install application.

Non-programming related question. Sorry. I had CppDroid for a long time, till I accidentally deleted its folder from internal storage. The app, crashed. I decided to uninstall. After uninstalling, however, when I tried to download it from Play Store, it wouldn't install, and would return error -24. I tried doing the steps needed to correct the error from google, but to no avail. I then downloaded the apk from a trusted source, but even that apk won't install. I can't find any solution on google. Help!

10/22/2017 1:25:04 PM

Kinshuk Vasisht

10 Answers

New Answer

+21

i'm unsure what is the issue/error. deleting a normal folder/file on sdcard should not cause much issues unless the app is installed on sdcard (fresh install fixes this normally). or the sdcard is having some problems i had some sdcards write locked before.

+20

which internal folder, can you elaborate? if you can delete your android app's storage cache try to do that from storage settings, remove all the internal, external files related to that app( backup somewhere else if you want ). explain in detail. did you delete the files from app-private storage with root?

+3

You could ask the CppDroid developers for help :)

+3

@Lord Krishna Sorry, Ill explain now. I deleted the folder /sdcard/CppDroid This folder contained the libraries and data of the app, after extraction. I did not delete the folder inside Android/data/, but after uninstall, I couldn't find it.

+3

The app is gone now. Ill try reinstalling after creating that folder.

+2

I tried. He seems to be busy.

+2

@Lord Krishna I have created the folder, and deleted all unknown odex files (Found just 2 ). But still, the apk cannot be installed.

+2

Nothing works. Nothing. I even deleted all the dalvik cache. And on booting, there was a notification - upgrading app _ of 110, but even after that the issue remained the same.

+2

@Lord Krishna I once tried to modify the app using LuckyPatcher. But that failed. It was done before I deleted the folder. But the app worked as I wanted. Maybe thats why I can't reinstall.

+2

I finally opened xda, and found that LuckyPatcher was the reason. I had that installed in my mobile from a long time. I am now installing the application as a seperate one, thanks to LuckyPatcher. Thank You!