Could you please help me with my project? | Sololearn: Learn to code for FREE!
New course! Every coder should learn Generative AI!
Try a free lesson
+ 1

Could you please help me with my project?

Tracking your BMI is a useful way of checking if you’re maintaining a healthy weight. It’s calculated using a person's weight and height, using this formula: weight / height² The resulting number indicates one of the following categories: Underweight = less than 18.5 Normal = more or equal to 18.5 and less than 25 Overweight = more or equal to 25 and less than 30 Obesity = 30 or more Let’s make finding out your BMI quicker and easier, by creating a program that takes a person's weight and height as input and outputs the corresponding BMI category. Sample Input 85 1.9 Sample Output Normal

16th Jan 2022, 12:39 PM
Sajjad
Sajjad - avatar
4 Answers
+ 1
Thanks ❤
16th Jan 2022, 2:10 PM
Sajjad
Sajjad - avatar
0
weight = int(input()) height = float(input()) check_bmi = round (weight / (height **2)) if check_bmi < 18.5: print("Underweight") elif check_bmi >= 18.5 and check_bmi < 25: print("Normal") elif check_bmi >= 25 and check_bmi < 30: print("Overweight") elif check_bmi >= 30: print("Obesity")
16th Jan 2022, 2:04 PM
Sajjad
Sajjad - avatar
0
This is my code but it contains error
16th Jan 2022, 2:04 PM
Sajjad
Sajjad - avatar
0
I couldn't find it
16th Jan 2022, 2:05 PM
Sajjad
Sajjad - avatar