installation error audiodiff | Sololearn: Learn to code for FREE!

0

installation error audiodiff

I tried to install audiodiff by 'pip install audiodiff' but at some point it throwed me following error : ERROR: Could not find a version that satisfies the requirement mutagen==1.21 (from versions: 1.16, 1.17, 1.18, 1.19, 1.20, 1.21, 1.22, 1.23, 1.24, 1.25, 1.25.1, 1.26, 1.27, 1.28, 1.29, 1.30, 1.31, 1.32, 1.33, 1.33.1, 1.33.2, 1.34, 1.34.1, 1.35, 1.35.1, 1.36, 1.36.1, 1.36.2, 1.36.3, 1.37, 1.38, 1.39, 1.40.0, 1.41.0, 1.41.1, 1.42.0, 1.43.0, 1.43.1, 1.44.0, 1.45.0, 1.45.1) ERROR: No matching distribution found for mutagen==1.21 I upgraded pip, installed mutagen 1.45.1 but then too its showing the same.

7/14/2021 7:18:42 AM

Sahil Jain

5 Answers

New Answer

+1

Hi @Sahil, Have you tried to uninstall mutagen and let pip handle the dependencies? If you have a specific version of a library already installed and you install another library that depends on another version of the first one, that will stop your installation process. Have a great day!

+1

I looked into the repo of audiodiff. It was updated the last time 8 years ago. You really should look for an alternative. I would not use such old libraries. Maybe it got irrelevant because a better library exists?

0

mutagen 1.45.1 requires Python >=3.5, <4... but audiodiff is written in Python 2.6 / 2.7 (do not support Python 3.x)

0

thanks @zen thanks @visph for the info, i was not familiar with all that. yes, now i understood the issue. but i need audiodiff for my experiment. is there any way out? if not, nevermind, i will change my algo

-1

you could try to install it from this github repo wich seems to have updated the code to be working with python3: https://github.com/SteveClement/audiodiff source of information: https://gitmemory.com/issue/clee704/audiodiff/1/761876146