I have a problem | Sololearn: Learn to code for FREE!
New course! Every coder should learn Generative AI!
Try a free lesson
+ 2

I have a problem

When you go out to eat, you always tip 20% of the bill amount. But who’s got the time to calculate the right tip amount every time? Not you that’s for sure! You’re making a program to calculate tips and save some time. Your program needs to take the bill amount as input and output the tip as a float. Sample Input 50 Sample Output 10.0

6th Feb 2021, 1:52 PM
Mahammad Qasm
Mahammad Qasm - avatar
14 Answers
+ 1
bill=int(input()) print(('bill' *20)//100)
12th Nov 2021, 1:48 PM
evans ronoh
evans ronoh - avatar
0
Please show your attempt
6th Feb 2021, 2:05 PM
∆BH∆Y
∆BH∆Y - avatar
0
they said to take bill amount as input like bill_amount=int(input()) and output the tip which is 20% of the bill amount so for 50 the tip will be 50*0.2=10.0
6th Feb 2021, 2:33 PM
**🇦🇪|🇦🇪**
**🇦🇪|🇦🇪** - avatar
0
To tell the truth i was 10 minutes straight stuck in the problem. The thing is the app wants you to subscribe to give you the full learning process. And with that i dont get the full knowledge
6th Feb 2021, 6:36 PM
Mahammad Qasm
Mahammad Qasm - avatar
0
bill = int(input()) #your code goes here bill*=0.2 print(bill)
10th Apr 2021, 1:39 PM
Mohit Fulfagar
Mohit Fulfagar - avatar
0
The devil is in the details of the question when it says use float. bill*=0.2 print (bill) I got stuck with this one but it says in the instructions to go with float
12th Aug 2021, 8:20 PM
GJD
GJD - avatar
0
bill = int(input()) bill*=0.2 print(bill)
17th Sep 2021, 5:06 PM
Adi Vaidya
0
bill=int(input()) bill *=0.2 print(bill)
12th Nov 2021, 1:54 PM
evans ronoh
evans ronoh - avatar
0
6th Dec 2021, 6:08 PM
Dilshodbek Fathiddinov
Dilshodbek Fathiddinov - avatar
0
this was my attempt that was wrong bill = int(input()) "x" = (input * 20 // 100) Print ("x")
13th Dec 2021, 3:23 PM
Morgan Matthews
Morgan Matthews - avatar
0
No solving with me
11th Jan 2022, 9:22 PM
Mohamedeid
- 1
Mahammad Qasm Everyone has same problem but where is your attempts?
6th Feb 2021, 3:37 PM
A͢J
A͢J - avatar
- 2
We know, you shall know, we not going to do your homework and show your attempt.
6th Feb 2021, 1:54 PM
Rellot's screwdriver
Rellot's screwdriver - avatar
- 2
And my attempts is that i will continue and be consistent in learning
6th Feb 2021, 9:19 PM
Mahammad Qasm
Mahammad Qasm - avatar