Error with pip ?? | SoloLearn: Learn to code for FREE!

+5

Error with pip ??

I have get these errors while using pip Google drive link :- https://drive.google.com/file/d/1-OGEey0JNAIqyT-6vLBi0QiqzarrXXty/view?usp=drivesdk I try to install pygame module , an error is coming ( you can see in above link ) I also try to upgrade pip , but the same error And you can also see pip version in Google drive link Please help me

9/18/2020 11:09:08 AM

Python

22 Answers

New Answer

+3

Today I am very happy , that i have solve pip errors , which i was having from one week I just uninstall python 3.4.0 and install python 3.4.4 And update setuptools and update pip to the version 19.1 Now , it is working fine Special thanks to stackoverflow

+4

Give the exact directory of the pip While downloading python, you would have not clicked at 'add to the path'. Use pycharm 🙌

+3

Namit Jain I am using submile text 3 and In setup there was no option to add to path , so I manually add pip and python to path and which directory of pip you are taking about

+3

Python [ Send Py Storms ] Oo Like for pycharm there is another command prompt and we have to activate the IDE first, see if this's the same with sublime

+3

https://youtu.be/xdj0mGmuNjc Check this ✌️✌️

+3

try pip3 install pygame... what happens?

+3

Oma Falk I have already try it , nothing happens , the same error comes

+3

did u find the pip script in your python installation?

+3

Tanmay Gupta I have already added pip to path , so I am not getting the error like pip is not recognized .....

+3

Oma Falk yes , I manually add pip to path

+3

I don't know if this is the problem but there were one time where I faced error because the python intrepretor I was using in the ide is different from the one in the path, this can happen if you have more than one python version

+2

Ruba Kh can you tell how can I check how many python version, I have

+2

Install a specific version of pygame that supports your python version i.e, python 3.4 edit: you can also try running this command python -m pip install pygame

+2

I would advise you to use Conda packages instead of pip. Pip is very annoying on local machines. Conda eases the python development environment, and helps with managing python packages seamlessly. However, it has a learning curve, not that long however, but still worth it in my opinion, it will save you lots of stress and time wastage

+1

I was using visual studio code but maybe this can help in sublime https://medium.com/swlh/setting-your-python-version-in-sublime-text-8e8a305e6701

+1

try to update pip and then try

+1

I cannot install pyaudio library in pycharm..

+1

Md Mahmood https://youtu.be/-3am_5jMzJ4 See this video , but from next time don't post your question in other questions

0

Why people don't want to learn other programming language

-1

help me I take care that when the blue box touches the yellow the yellow disappears please https://code.sololearn.com/Wlg44q4f2JK6/?ref=app