React Native Elements problem[Solved] | Sololearn: Learn to code for FREE!

+2

React Native Elements problem[Solved]

In simple words, can somebody give me a link to working react native elements example in expo snack ? Because all of the examples are causing the same error which is expo is being unable to resolve react-native-elements even when it's added in package.json or installed globally(on local device)

6/29/2020 9:15:54 PM

WARLORD

10 Answers

New Answer

+3

WARLORD the official example is working https://expo.io/@monte9/react-native-elements-app Tho the code is inaccessible in expo, after a little bit of researching i found the github repo with the code https://github.com/react-native-elements/react-native-elements-app

+3

Burey btw the test that i'm talking about was local because for some reason snack keeps saying it's unable to resolve the module(even when I saved and refresh the project)

+3

WARLORD good to hear it been resolved You can use this site to find what icons each library has https://oblador.github.io/react-native-vector-icons/

+2

There is this course on Udemy which teaches you step by step. It was free back then. https://www.sololearn.com/post/259464/?ref=app https://code.sololearn.com/WKKkpq0efxai/?ref=app

+2

Gordon I asked simply for a working snack of react native elements library not a react native course

+2

You learn about installation and settings in a course.

+2

Gordon I appreciate that trying to help but my problem that I literally didn't find any expo snack that works with react native elements, all of the snacks are producing the same error which is expo is being unable to resolve module react native elements even when trying to install any of the following two versions in my project or globally it doesn't work and produces the same error: "react-native-elements": " ^2.0.0" (from github) Or "react-native-elements":" 2.0.3" (the most recent version)

+2

Burey I found a solution which is to import FontAwesome5 instead of Icon(for some reason icon doesn't show font awesome :/) Thanks for helping anyway

+1

Burey I tried to copy the dependency from this repo but the icon component doesn't work and shows "?" Instead of a simple icon like "eye"

0

WARLORD on a side note Expo is nice and all, especially when the project is small and doesn't require many features. But it is very limiting when you want to use libraries written in native code. If the library hasn't been integrated to Expo you simply wouldn't be able to use it. Also ejecting leaves you with some Expo dependencies and issues that may be hard to fix. I am currently working on a large project that been started with Expo and been recently ejected to the bare workflow and very so often i am finding myself fighting with some of the left over dependencies of Expo...