Pip install not working [GIVEN-UP] | Sololearn: Learn to code for FREE!


Pip install not working [GIVEN-UP]

Everytime I type in pip in the cmd it comes up with a load of nonsense. The mess of errors ends with a "Importation Error: Cannot Install CertificateError" I uninstalled then reinstalled Python completely and it STILL won't work. It is in the environment variables. I am seriously on the verge of giving up Python completely because this has been all year and NO ONE has helped

8/23/2019 3:05:49 PM

Clueless Coder

8 Answers

New Answer


Well "py -m pip install" worked for me. If it doesn't work, try "python -m pip install" instead. But if that wasn't the problem I must say that I also have problems with installing libraries, because "SSL isn't installed".


Are you sure you entered the command right?


Seb TheS It used to work. I downloaded Pygame and MatPlotLib through "pip install" I then upgraded the pip and now it won't work, even after uninstalling and reinstalling


I already tried that. I've tried a tone of stuff. Like "pip3 install" for example, nothing works


Does it say something about SSL or other widget that is not installed?


Seb TheS It repeatedly talks about Urllib3, and CertificateError. It does mention SSL but that was in a path for the location of a file. It was like 60 lines error


çłůěĺęşş čøðêř I might not be able to help, I might have similar problems.


It's annoying because I want Tensorflow for Python. Pydroid charges you extra for the ONE library I want. Thanks anyway