Old Language Versions | Sololearn: Learn to code for FREE!

+1

Old Language Versions

Only I can't understand why SoloLearn uses pretty old versions of JVM languages? Examples: Kotlin -> https://code.sololearn.com/ck367cXcSB5u/ Java -> https://code.sololearn.com/cH8j2HEd2CHe/

4/3/2018 1:21:00 AM

ISkylake

2 Answers

New Answer

+5

Older versions are more fail-safe. New versions come with bugs and users can take advantage of those bugs and ruin SL servers. Thats why most software recommends to you for you to use an older, fully tested and fail-safe version than new fresh releases.

+1

Hmm.. Okay.